Service Incident Update for CE

Incident Report for Netcore Cloud

Resolved

Dear Valued Customer,

We are pleased to inform you that the platform performance issue has been fully resolved. All services have been restored to normal operation.

If you continue to experience any problems, please do not hesitate to contact our support team. You can check our Status Page at "https://status.netcorecloud.com for further updates or information on this incident.

Thank you for your understanding and patience during this time.

Best regards,
Team Netcore Cloud
Posted Apr 18, 2026 - 17:54 UTC

Monitoring

Dear Valued Customer,

We are pleased to inform you that the platform is now up and running, and core functionalities have resumed.

Current Update:

Uploads, Campaigns, Journeys, and Report Generation impacted during the incident are currently being replayed and processed.
You may experience temporary slowness in data uploads and report updates on the UI due to backlog processing.
Performance is expected to gradually stabilize within the next 1–2 hours.

Our team continues to closely monitor the system to ensure full restoration and smooth operations.

Thank you for your continued patience and support.

For real-time updates, please visit: https://status.netcorecloud.com

Best regards,
Team Netcore Cloud
Posted Apr 18, 2026 - 13:01 UTC

Update

Dear Valued Customer,

We would like to inform you that the platform performance degradation is still ongoing. Our engineering team continues to actively investigate and work on resolving the issue to restore normal performance at the earliest.

Here’s what we know so far:

Incident Details:

Issue: Platform slowness
Impact: Campaigns, Journeys, Uploads, and Segment Refresh functionalities may be affected
Status: Investigation and mitigation in progress
Next Update: By 6:00 PM IST

We sincerely apologize for the continued inconvenience and appreciate your patience while we work on resolving this issue.

We will continue sharing progress updates, and the next detailed update will be provided by 6:00 PM IST.

For real-time updates, please check our status page at: https://status.netcorecloud.com

Thank you for your patience and understanding.

Best regards,
Team Netcore Cloud
Posted Apr 18, 2026 - 10:37 UTC

Update

Dear Valued Customer,

We would like to inform you that the platform performance degradation is still ongoing. Our engineering team continues to actively investigate the issue and is working towards restoring normal performance at the earliest.

Here’s what we know so far:

Incident Details:

Issue: Platform slowness
Impact: Campaigns, Journeys, Uploads, and Segment Refresh functionalities may be affected
Status: Investigation in progress
Approximate ETA: 2 hour

We sincerely apologize for the continued inconvenience and appreciate your patience while we work on resolving this issue.

We will continue to provide updates as soon as new information becomes available.

For real-time updates, please check our status page at: https://status.netcorecloud.com

Thank you for your patience and understanding.

Best regards,
Team Netcore Cloud
Posted Apr 18, 2026 - 08:42 UTC

Update

Dear Valued Customer,

We would like to inform you that the platform performance degradation is still ongoing. Our engineering team continues to actively investigate the issue and is working towards restoring normal performance at the earliest.

Here’s what we know so far:

Incident Details:

Issue: Platform slowness
Impact: Campaigns, Journeys, Uploads, and Segment Refresh functionalities may be affected
Status: Investigation in progress
Approximate ETA: 2 hour

We sincerely apologize for the continued inconvenience and appreciate your patience while we work on resolving this issue.

We will continue to provide updates as soon as new information becomes available.

For real-time updates, please check our status page at: https://status.netcorecloud.com

Thank you for your patience and understanding.

Best regards,
Team Netcore Cloud
Posted Apr 18, 2026 - 06:11 UTC

Investigating

Dear Valued Customer,

We are currently experiencing platform performance degradation, which may result in slower response times. Our team is working diligently to resolve the issue at the earliest.

Here’s what we know so far:

Incident Details:

Issue: Platform slowness
Impact: Campaigns, Journeys, Uploads, and Segment Refresh functionalities may be affected
Status: Under investigation
Approximate ETA: 1 hour

We will continue to provide updates as soon as new information becomes available.

For real-time updates, please check our status page at: https://status.netcorecloud.com

Thank you for your patience and understanding.

Best regards,
Team Netcore Cloud
Posted Apr 18, 2026 - 04:14 UTC
This incident affected: US (CE - Dashboard, CE - Campaign Email, CE - Campaign SMS, CE - Campaign APN & BPN, CE - Journeys, CE - Uploads, CE - Segmentation, CE - Reports).