We are pleased to inform you that all of our IPs previously listed in the Spam CSS by Spamhaus have now been removed. While email delivery has been restored for most messages sent through our CPaaS platform, please note that it may take a few more hours for recipient MX servers to update their spam filters and fully normalise email delivery.
We kindly request that you monitor your email delivery and confirm if everything is functioning as expected.
If you experience any issues with email delivery, please feel free to reach out to us at help@netcorecloud.com.
Thank you for your understanding.
Best regards, CPaaS Support Team, Netcore Cloud
Posted Nov 08, 2024 - 12:25 UTC
Identified
Dear Valued Customer,
We wanted to update you that most of the IP networks previously listed in Spamhaus CSS listing have been removed. However, a few networks are still awaiting de-listing, which may cause intermittent delivery issues to certain corporate and other domains.
Please note: Even after full de-listing, it may take additional time for MX servers of the recipient domains to synchronise with this change and update their spam filter policy, which could temporarily affect email delivery.
We are actively working with Spamhaus to expedite the de-listing of all IP networks and will keep you updated as we progress.
Thank you for your patience.
Best regards, CPaaS Support Team
Posted Nov 08, 2024 - 09:47 UTC
Investigating
Dear Valued Customer,
We are currently experiencing intermittent issues with email deliveries to certain corporate and Yahoo domains. This problem is due to a false positive listing of our network with Spamhaus. Our internal monitoring systems detected this issue last night, and we have been actively coordinating with the Spamhaus team to resolve it as quickly as possible.
Spamhaus has acknowledged that the listing was caused by an issue on their end, which has affected not only Netcorecloud but also several other global email service providers.
Actions Being Taken: 1. Identifying Impacted IPs: We are in the process of identifying the specific IP addresses affected by this listing. 2. Implementing Necessary Changes: Our team is making the required adjustments to ensure the timely delivery of your emails. 3. Collaborating with Spamhaus: We are in ongoing discussions with the Spamhaus team to prioritize and expedite the removal of our network from their blacklist.
Expected Resolution Time: Tentatively 8-12 hours.
What You Can Do: 1. Monitor Your Emails: Please keep an eye on your email deliveries during this period. 2. Report Issues: If you continue to experience any problems with email deliveries, do not hesitate to contact us at help@netcorecloud.com
We apologise for any inconvenience this may cause and appreciate your patience and understanding as we work to resolve this matter swiftly.
Thank you for your understanding & continued trust in Netcorecloud.
Best regards, CPaaS Support Team, Netcorecloud
Posted Nov 08, 2024 - 05:24 UTC
This incident affected: APAC (CPaaS - Email), US (CPaaS - Email), India (CPaaS - Email), and EU (CPaaS - Email).